Informational - OCCHD Service Alert: Windows 11 update (25H2) deployment beginning Thursday, March 19, 2026 (CS3022597)

Incident Report for OCC

Resolved

This maintenance has been resolved.
Posted Apr 13, 2026 - 11:59 EDT

Investigating

Notification Description: Device and Desktop Engineering (DDE) will begin deploying the Windows 11 update (25H2) to all Windows 11 ATH imaged machines during the regular maintenance window on 03/19/26. Deployment will occur in stages over the following 4 weeks, in coordination with our DDE partners.
Affected application: All Windows 11 ATH imaged machines

Requested actions: Please ensure that all Windows 11 ATH imaged machines remain powered on and connected to the network during this time frame so they can receive the update.

If you have any questions, please contact the OCCHD at 866-651-3180 or via the Portal https://portal.occhdsupport.com.

Users can check the operational status of OCCHD-supported applications, subscribe for updates, and view notification history by visiting OCCHD's Status Page at https://status.occhdsupport.com/
Posted Mar 19, 2026 - 08:58 EDT